Forum

Sharing my DUH!! Moment  

  RSS

Mike Price
(@pricemi115)
Eminent Member
Joined: 3 years ago
Posts: 20
December 16, 2018 3:15 EDT PM  

Figured I'd share this in case anyone else out there runs into this "not so helpful" error message. I recently purchased a 2018 Mac mini to replace my aging Mid-2010 MacBook Pro. For the past year or so, I have been debating whether my next computer would be a desktop anchored system or a laptop. Since my MBP lost WiFi about 1.5 years ago, I am pretty comfortable with the desktop system - so I went with the Mac mini. However, there are times when I might prefer to be with the family but still need to do some things on the computer. So part of my plan was to convert the MBP into a sort of "dumb terminal" and VNC back to the Mac mini. Now that the Mac mini is all set up, I turned my attention to the MBP. Since the SSD that was the primary drive on the old MBP is now the destination for my bootable clone of the Mac mini, I put the rotational drive back into the MBP. Having listened to MGG and Maccast for many years, I have a USB flash drive with bootable images of the past two operating systems. When I went to install High Sierra as a clean install on the MBP, I kept running into an error when going to install the OS starting that "This copy of the Install macOS High Sierra.app application is damaged and cannot be used to install macOS". I re-created the bootable image a few times and even when so far as to download a fresh copy of 10.13.6 and use that. They all gave the same error. Then with a little google foo - the problem became clear. As I hinted above, I needed to crack open the laptop to perform the hard-drive dance. In doing so, and following iFixIt's directions, I disconnected the battery. When I put it all back together, everything worked*, but without power for 20 minutes or so and with a dead CMOS battery (is it still called a CMOS battery??), the computer thought it was 2001 and my install was from the future!! DUH!! So the key validation was failing. Reset the time to today, and the install ran fine, but that error, while correct, was not helpful!!

A couple of other things:
- I also discovered, since I used a bluetooth trackpad most of the time and I also use the tap-to-click, somewhere along the line, the built-in trackpad lost the ability to register click events.

- Any why-o-why, does  think it is appropriate to block me from downloading (just downloading) older/incompatible operating systems onto my Mac mini?? While in the end, I did not really need an updated installer for High Sierra, blocking the download is overkill. I may be using one system to support another (older system). Block the installation, but not the download !!
Thankfully, I was able to get my fresh download of High Sierra with another MBP.


Quote
Dave Hamilton
(@davehamilton)
Admin
Joined: 21 years ago
Posts: 488
December 16, 2018 5:25 EDT PM  

Thanks for sharing this @pricem115. The clock is *such* an easy thing to overlook, especially in that scenario... and yet so vital!


ReplyQuote
datafornothinandbitsforfree
(@datafornothinandbitsforfree)
Reputable Member
Joined: 10 years ago
Posts: 253
December 16, 2018 10:18 EDT PM  

Any why-o-why, does  think it is appropriate to block me from downloading (just downloading) older/incompatible operating systems onto my Mac mini??

Apple has been systematically simplifying its product line for the non-geek, non-tinkerer, non-technical user.

A software version that will not run on a given Mac will just increase support calls and make unhappy the non-technical Apple user.

Apple is perfectly happy to annoy the technically aware and the tech-savvy Apple media, because they have found they sell more products, make more money, and get higher satisfaction survey scores catering to the non-technical users.

NOTE: I would also find it useful to be able to get any specific version of macOS or older apps when I find I need them for older generation hardware.  That doesn't stop me from observing and in many ways understanding what Apple is doing and why.


ReplyQuote
Mike Price
(@pricemi115)
Eminent Member
Joined: 3 years ago
Posts: 20
December 17, 2018 5:43 EDT AM  

As a software engineer, I do understand @datafornothinandbitsforfree the value of decreasing the potential for support calls....especially when the customer volume is the size of Apple's. However, they already removed the operating system downloads from the view of the non-tech users. You need to go thru a special dance already...as noted on this great site, macobserver.com 😁 { https://www.macobserver.com/tips/quick-tip/download-high-sierra-installer-under-mojave/}. So with this incantation, I can get to the High Sierra download, but then  will tell me it is unable to download. If I got this far and if the install were to fail to execute (which it will) due to system incompatibility, that should have covered the luddite use case. .....thanx for letting me vent 😀

@davehamilton: On some future show, you & John may want to cover the even higher importance of maintaining a historical copy the app installs for those that support many Macs. I would also be interested in knowing if I was running Mojave on a system that supported High Sierra, would the download have worked???

This post was modified 10 months ago by Mike Price

ReplyQuote
datafornothinandbitsforfree
(@datafornothinandbitsforfree)
Reputable Member
Joined: 10 years ago
Posts: 253
December 17, 2018 7:01 EDT AM  

I forgot about becoming a paid developer ($99/year). That gives you access to many of the older macOS versions.

Personally I always download at least 1 copy of each .0 major release, and keep it around, just in case.


ReplyQuote
Mike Price
(@pricemi115)
Eminent Member
Joined: 3 years ago
Posts: 20
December 17, 2018 7:05 EDT AM  

While expensive if only for access to the older installs, that is a good thing to remember. Thanx.

Also - Apple does allow the .mpkg downloads of the older installs, but I do not think these are able to create the bootable usb volumes, which is what I was after, especially since the system in question had no OS (or recovery OS)


ReplyQuote
Mike Price
(@pricemi115)
Eminent Member
Joined: 3 years ago
Posts: 20
December 17, 2018 7:41 EDT AM  

ReplyQuote
Mike Price
(@pricemi115)
Eminent Member
Joined: 3 years ago
Posts: 20
December 17, 2018 8:02 EDT AM  

@datafornothinandbitsforfree - I need to recant my allegation that the installer is not available. You just need to dig really deep !! 
> Download the installer package from apple support. For High Sierra: https://support.apple.com/downloads/highsierra
> Expand the contents of the downloaded package via "pkgutil -- expand" & poke around
> Go into the package: EmbeddedOSFirmware.pkg
> Mount ./EmbeddedOSFirmware.pkg/RecoveryHDMeta.dmg
> In the resulting volume, mount ./BaseSystem.dmg
> The installer app is in the resulting volume !!

Screen Shot 2018 12 17 at 8.03.58 AM

** I'd have to say this is pretty well protected from the luddite.....and many of the tech-savvy too 🤣

This post was modified 10 months ago 2 times by Mike Price

ReplyQuote
Graham McKay
(@kiwigraham)
Reputable Member
Joined: 3 years ago
Posts: 297
December 18, 2018 8:38 EDT PM  

Date manipulation for installer USBs is something I remain aware of for my old OS X versions where the certificate has expired. So I have a reminder taped to the USB stick to use terminal to enter the date command before running the installer:

date 0201010116 

ReplyQuote
Mike Price
(@pricemi115)
Eminent Member
Joined: 3 years ago
Posts: 20
December 18, 2018 9:04 EDT PM  

Great thought, @kiwigraham. My flash stick is a real little thing, so maybe I'll just keep it in a ziplock bag along with the reminder note 🙂


ReplyQuote
Share: