Forum

Having challenges with Synology WebDAV  

   RSS

0

I would sincerely appreciate any and all assistance with Synology WebDAV.  I have the service running with permissions granted to a particular user; however, when I log into the Synology with this user to set up the WebDAV, I receive an error message that "this user account" does not have sufficient privileges.  Suggestions?

Screen Shot 2019 08 20 at 6.08.40 PM

 

The user group as well as the user have read/write privileges for the WebDAV service.  Thanks everyone

@jforbush

I've not done this before and don't have a Synology to look at, but at first glance it looks to me like you're trying to do some configuration of the webdav service and I would expect that only an administrator on the Synology would be allowed to do that?

Correct, but I’m also the administrator, logged in with the admin account.

@jforbush

do you mean the default admin account or another administrator account that you have created? I would not recommend to use the default admin account and ideally disable it after creating another user with administrator privilege. Also, you seem to contradict yourself since you said you were logged in with the new user created to use WebDAV, but then on your reply to @jforbush you said you were logged in as admin. So which is it?

3 Answers
0

@jefflambert670

yeah, that's what I did, but for reasons that aren't clear, the user account (with which I would have DevonThink log in with) can't access WebDAV.  I've reached out to Synology.

@jforbush

In Control Panel, Users, when you click on the user, you select your DevonThink user, than Edit. Make sure you have granted permission to see the sharpoint on which the data is located, and that the Devonthink user has Read/write permission on that sharepoint. Then go to the applications tab and make sure the WebDAV Server is Allow. This should work. Maybe you have Unix permissions enforced for the Sharepoint?

0

well, that's good that it "fixed" the issue, but if you don't want to have an "improper shutdown" maybe you could use a APC backup type device? It saved my bacon countless time with all the power cutout we have.

@jefflambert670

I say "fixed" as I believe the Synology is dead in the water!!!

Yeah, I have everything on a battery backup including this Synology which I can no longer access either through the Quickconnect feature or internally via IP. When I return to the site on Monday afternoon, I'll directly plug into the Synology to see if I can access it, but in the meantime, I'm shopping for a new Synology.

-1

@jefflambert670

My apologies for the confusion. I'm not sure what happened to my previous reply, but nonetheless, I am using another administrator account that I created to authorize the WebDAV service.

I then created a new non-administrator account so that I could use web data of with DevonThink; however, despite (seemingly) confirming that this account has WebDAV permissions, when I login with this non-administrator account and then select " WebDAV", I received the error message that "this user account has not been assigned proper privileges to perform this action".

I thought perhaps it might've been user account specific and, as such, created another user account only to receive the same error message.

Ultimately, what I want to do is to create a web app server so that I can use DevonThink web server over WebDAV.

@jforbush

Normally, you use the admin account to activate the sharing options, in your case WebDAV, set the permission so the user, the one that will login for your Devonthink database, will have access to the correct sharepoint and access to the service WebDAV. THEN, you go to the mac, and login with your https address and port of your Synology with your Devonthink user and it should work. If you have to setup something IN Devonthink, same principle, you just use your Devonthink user to login to the https://youripaddress:5006 or what ever port you decided if it's not the default one. It should work.

well...it would appear that my issue has been "solved" as while in the middle of a backup, the Synology went kaput (it would seem) via an "improper shutdown".

Share: