Forum

NAS to NAS backup (Drobo specific hopefully)  

  RSS

0
For years I've been backing up my newer Drobo to my older Drobo using Chronosync on a Mac mini. It works, but it's fragile as all get out. The Mac mini is on WiFi (unavoidable) so it decides to change networks from time to time, there are s/w updates that disengage the Mac mini, Chronosync gets its panties in a bunch about some file, the Drobos dismount in spite of the AppleScript i have running to mount them.
 
I'm looking for a solution to back up one Drobo to another directly. They're both hard-wired to the same router and sitting smack dab next to each other, so it seems foolish to go over WiFi to a distant room and back and have this Mac in the middle.
 
I tried Resilio Sync, but it uses SMB and that gets borked up if you also use SMB to access the Drobos. The (good) folks at Resilio told me the only good way to use it would be to have an intermediary device like a Mac (so I'd be back where I started.).
 
I was looking at OwnCloud and that might be an option but I haven't cracked the (very complex) code on how to set it up. It says I have zero space on all of my shares.
 
Any ideas?
 
0

Good question (and good cause to create a NAS-specific Q&A forum here... I moved your post, @podfeet!).

Is there no longer a 'copy' app on either of your Drobos? Speaking of, which model Drobos do you have? I just found it on my Drobo 5N in the Drobo Apps > Other Applications section. I think it's exactly what you want (but I could be wrong!).

Alternatively you could go in and use 'rsync' from an SSH session, but obviously a little smoother/easier to do it in the GUI/app.

 
1

w00t - glad you created a NAS section @davehamilton.  Seemed like there should be one.

I've got a 5N and a 5N2, with my desire to back the 5N2 up to the 5N. I don't see Copy on either one of them in the new firmware. It's highly improved lately, btw.  Pretty icons and better sorting.  

 
0

Ok, I must have installed copy on my Drobo from a 3rd-party source. I've checked both DroboPorts and DroboWorks and... nada. Interestingly, if I search for 'copy Droboapps' I find a link to  http://www.drobo.com/drobo-solutions/drobo-apps/copy/ but... it doesn't go where one would expect. Maybe this has been deprecated.

 
1

And sadly that's a common occurrence on Drobo's website. There are lots of dead links.  Their support pages where they store their manuals has been down for at least the last 5 days (that's when I notified them and they said they'd "get right on it.")

 
1

I feel like Drobo is still clawing its way back to a good place. I bought a 810n about 2 years ago when they were offering 2 free SSD's with the unit, it does well though very sensitive with drives not meeting Drobos high health bar. I'd tried using CrashPlan when it was supported to copy from and to the 810n but it was beyond difficult to set up and maintain, that option is gone now regardless.

I haven't tried it yet but the DroboDR app option seems like a decent option if one has the proper Drobo Hardware (810n or 5n2) see more here on the Drobo Blog:

Is Your Data Protected in the Event of a Disaster?

I'm going to go out on a limb @podfeet and guess the 5n doesn't work with the 5n2 for DroboDR. I wonder if another solution is trying to use Hazel on your Mac Mini and just have it watch your Drobo 5n2 and for changes and sync them? Of course, that doesn't solve the network and other issues you mentioned in your original post... too bad we can't run something like Hazel,etc., on a Raspberry pi which could be connected via ethernet to the hub. Could be a cheap(ish) solution if an app like that existed. 

 
1

Your guess is correct, @Willdesign. I asked them and it's only for 5N2 to 5N2 (maybe others too).  They didn't give me a reason why it can't run on the 5N though. I suspect it's not a technical solution.

I could use Hazel, but that would be more of a hack than using Chronosync which is designed to do exactly this, and would still involve a separate computer. I did improve the fragility of the setup by moving the Mac mini away from my TV (it was a media server) and instead putting it in the same room with the router and the two Drobos.  So far it's been MUCH more stable now that the Mac mini isn't changing networks.

I wrote up my final post about it here:

The Great Drobo Migration of 2018

It's not favorable to Drobo at all.

 
Share: