Forum

[Solved] VPN server on Synology  

  RSS

0

HI guys, I know that Dave got this setup at some point, so I'm hoping I'll chime in, if not, and you know how to do this. Please help.

I have setup a VPN on my Synology. I'm using OpenVPN, this works as in, I can connect back to my Synology with AFP with the IP range from the vpn. Now I have clicked the allow vpn to access LAN's devices, which, in theory should enable me to see my Macs on my remote LAN. I'm usually using Apple Remote Desktop and don't know how to set it up so I can see all my Macs. Should I see them under my VPN Range IP? or the remote LAN IPs? They don't show in Local network.

If I can't make this work, are there other software that would enable me to see my whole network from remote. I'm not talking about a VNC client, but so I can see my printer's web page, copy files to different Macs and stuff like that. I used Slink some time ago but it's not supported anymore. I used Sharetools before that but it's gone the way of the dinosaurs too.

TIA!

So, just to let you know, I figured it out. You need to enter the remote IP range in Remote desktop so for me my Local IPs are 192.168.2.x and the remote LAN is 192.168.3.x so I entered Network range from 192.168.3.1 to 192.168.3.255 and got a list of all my machines. Also, I was able to connect to my server with it's IP from the local range and not the VPN assigned IP.

0

Still struggling to get my VPN to work 🙁

 
0

@jforbush, did you make sure that your port-forwarding was setup correctly on your router? I had trouble at first because I had connected more than one LAN port to my switch so the modem/router was having trouble routing it to the correct IP adresse. After removing all but one of the Ethernet cable, restarting the router, it worked ok.

to the best of my knowledge I have, but I'll double check!

1

You should be able to see your Macs by connecting to their internal IP addresses. If your internal network range is 192.168.1.x and your iMac is at 192.168.1.5 then that's it's IP address, regardless of what you get from your VPN. 

And, with Synology's VPN, the VPN server takes care of "routing" from your VPN IP address to your other "internal" IP addresses.

What generally doesn't work across a VPN connection is Bonjour/Zeroconf. So you won't likely see all your devices showing up in "Shared" in the Finder. You'll have to manually connect with Go > Connect to Server in the Finder, and then using various different protocols for different types of connections. Using the example of an iMac at 192.168.1.5, we would do the following:

File Sharing: smb://192.168.1.5
Remote Control/Screen Sharing: vnc://192.168.1.5

And so on and so forth.

Thanks @davehamilton, I had finally figured it out. I know you now have Gigabit internet at home, so what's the maximum speed you get when you connect through your Synology VPN to your Diskstation? I'm getting about 10 MB/s write and 16.5 MB/s read and we have Gigabit at work both for upload and download, and I have the same thing at home, so I'm guessing that the problem is with the VPN. It's an older Synology DS1813+ so maybe that's why? What do you think?

I haven't really tested read/write speeds in that sense. I get full gigabit reads and writes to my DS1817+ locally, but my "gigabit" speeds are only in one direction. Xfinity does 1000down and 40up (or so). And I'm doing my VPN through my Synology router, not my DiskStation... so, yeah, lots of variables.

Mainly I just use VPN for access, not xfers.

1

I work from home, I do mainly Photo retouching, so big files to transfer, not as big as video files but still. We had 300/300mbps before and I pushed to get the 940/940mbps at work. It does go a bit faster but maybe 30% faster, not 300+% faster. I'll do a test over HTTPS and webdav and see if I get better speeds and report back. it's not ideal, but I could go that route If I have something very big to transfer.

 
1

man, what a difference Webdav makes!!! I made a drive with Transmit connected through HTTPS (webdav) and tested with Blackmagic disk speed test. I know it's for regular drives and not network drives, but it can help see the difference anyway.

speedtest webdav

I also tested with the finder (still with the same transmit mounted volumes) transfering a 218 MB file to and from the server and with iStat menu was able to confirm the write speed at around 25MP/s and when I copied the file back ton my desktop it was instantaneous, like not even the time to register a speed in iStat! So, that's pretty nice:-)

This post was modified 3 weeks  ago by jefflambert670
 
Share: