Forum

The TL;DR on Apple'...
 

The TL;DR on Apple's macOS Mojave 10.14.4 Gmail/G-Suite Issue: It's Fixed  

Page 1 / 2
  RSS

Dave Hamilton
(@davehamilton)
Admin
Joined: 21 years ago
Posts: 487
March 30, 2019 2:10 EDT PM  
wpf-cross-image

Earlier this week many folks began experiencing an issue where macOS Mojave 10.14.4 could not properly log in to some Gmail-based accounts, mostly those using G-Suite for custom domains. The good news is that, as of late last night, this problem appears to have been eradicated.

Our best guess is that this was a Google-originated problem, at least this week. Here's the timeline that leads us to this conclusion:

  • January, 2019 – Early in the 10.14.4 betas, developers and other beta testers reported having this exact issue. It then went away, though it's hard to tell if Apple took any specific action to fix it.
  • Monday, March 25, 2019 – macOS Mojave 10.14.4 was released. Anyone updating on this day had no issues.
  • Tuesday, March 26, 2019 – Folks began having the aforementioned authentication loop/fail issue and were unable to retrieve mail with macOS Mail.app from some Gmail accounts. A few also reported issues with iOS, though reports on that were spotty, at best.
  • Also on Tuesday, March 26, 2019 – Google announced they rolled out some changes to G-Suite authentication. These primarily talk about changes to two-factor authentication while the bug affected folks with and without that, but the timing is too coincidental to ignore.
  • Tues-Friday, 3/26-3/29/2019 – The web blows up about the issue, folks are scrambling trying to sort out various solutions and workarounds. One of these fixes involved using Charles, a piece of proxy software, to intentionally play a "man-in-the-middle attack" on your Mac, inserting itself as Google's authentication servers, passing back a piece of information that was missing from Google's own response.
  • Late-night, Friday, 3/29/2019 – The problem simply goes away, seemingly without Apple having made any changes to macOS on anyone's Macs.

Adding together the timing of when the issue started, Google's G-Suite authentication announcement, the method by which the "Charles workaround" worked, and the timing of the solution, our interpretation is that Google fixed the issue on their servers last night and now all seems to be well for everyone from whom we've heard. And ourselves. Our long, international nightmare is now over.

This topic was modified 7 months ago 7 times by Dave Hamilton

Quote
(@chuhaitime)
New Member
Joined: 2 years ago
Posts: 4
March 31, 2019 6:02 EDT PM  

It might be better, but it's not 100% fixed.  As of Sunday Match 31 at 6 pm, I am still getting random periodic Login Failed messages.

If I click the message, it logs-in OK and stays that way for a few hours and then the log-in drops again.


ReplyQuote
ASLReBecca
(@aslrebecca)
New Member
Joined: 7 months ago
Posts: 2
March 31, 2019 7:51 EDT PM  

I'm still shut out, so it's not fixed everywhere. I cannot be the only one.


ReplyQuote
Dave Hamilton
(@davehamilton)
Admin
Joined: 21 years ago
Posts: 487
March 31, 2019 8:55 EDT PM  

Interesting. What kind of account is it, Gmail or GSuite?

And what symptom are you seeing? Are you getting successfully through the login process in the Private Safari window?


ReplyQuote
Dave Hamilton
(@davehamilton)
Admin
Joined: 21 years ago
Posts: 487
March 31, 2019 8:56 EDT PM  

So the login process (now) works for you, whereas previously it wouldn’t, right? Or is that failing silently?

I guess the question is: after you login, are you able to get Mail?


ReplyQuote
(@chuhaitime)
New Member
Joined: 2 years ago
Posts: 4
March 31, 2019 9:02 EDT PM  

Gets through initial Safari verification process and gets mail for a few hours.  Then fails silently with Verification failed message at top right of Mail screen and ~ character opposite account in list on left.  Clicking the Verification failed message enables it to log-in again until it fails silently again a few hours later.

gmail not gmail suite


ReplyQuote
Dave Hamilton
(@davehamilton)
Admin
Joined: 21 years ago
Posts: 487
March 31, 2019 9:08 EDT PM  

Huh. That seems like a different issue. Still a problem, of course, just not this problem. The web authentication is working.

In fact, now that I think about it, I’ve seen your problem before... it’s just that, pre-10.14.4, Mail could recover without the bonus login window. I could click the “disconnected” icon and it would attempt and succeed. I don’t think this one is new.

Curious: did you ever have the login-window-fail problem we’ve been tracking here? Given that you have a Gmail account, I figured it was worth asking.


ReplyQuote
(@chuhaitime)
New Member
Joined: 2 years ago
Posts: 4
March 31, 2019 9:23 EDT PM  

Yes, it started (see below) with the Safari verification bug appearing, which required two or 3 attempts to get past.  Now it verifies first time no problem but goes on to fail silently a few hours later.

It started suddenly from 10.14.4 beta 6—never a problem before that.


ReplyQuote
ASLReBecca
(@aslrebecca)
New Member
Joined: 7 months ago
Posts: 2
March 31, 2019 10:19 EDT PM  

I'm on a Mac, have never had this problem before, updated the system last night, and today I got the request to verify my account through Safari. So I did this and went back to Outlook. I cannot get Outlook to recognize my gmail account at all.


ReplyQuote
(@monique_buchanan)
New Member
Joined: 6 months ago
Posts: 2
April 5, 2019 10:13 EDT AM  
  • Late-night, Friday, 3/29/2019 – The problem simply goes away, seemingly without Apple having made any changes to macOS on anyone's Macs.

Adding together the timing of when the issue started, Google's G-Suite authentication announcement, the method by which the "Charles workaround" worked, and the timing of the solution, our interpretation is that Google fixed the issue on their servers last night and now all seems to be well for everyone from whom we've heard. And ourselves. Our long, international nightmare is now over.

No, for me this problem is not fixed and it is a nightmare. I have three gmail accounts and all were working fine until the 10.14.4 update. My emails are not downloading to my Apple Mail even though I did what the error message said and authenticated through Safari.


ReplyQuote
(@monique_buchanan)
New Member
Joined: 6 months ago
Posts: 2
April 5, 2019 11:09 EDT AM  

Incidentally, this issue is also causing problems with my Apple Calendar accounts, since I use Google for my calendar.


ReplyQuote
(@sara_nichols)
New Member
Joined: 6 months ago
Posts: 1
April 6, 2019 3:35 EDT PM  

Still having this issue. The only temporary fix is quitting mail, then opening back up. It works for awhile, then I get the offline symbols again. It's not asking for log in, just giving the symbol. Forcing them to go online also doesn't work. Hope they fully fix this soon.


ReplyQuote
Wylienet
(@wylienet)
New Member
Joined: 6 months ago
Posts: 1
April 8, 2019 6:09 EDT AM  

This just worked for me. I've been having the same problems over the last week using my Gmail accounts in Apple Mail. However, I also noticed yesterday that a piece of malware (Datatransportation) kept popping up and freezing my screen. I ran Malwarebytes to try and remove it, restarted my MacBook and hey presto, my Gmail in Apple Mail is now working again. Not sure if it's a coincidence or not, but perhaps the Gmail issue was actually a malware issue?


ReplyQuote
(@mark_lierley)
New Member
Joined: 6 months ago
Posts: 1
April 8, 2019 4:10 EDT PM  

Not so much fixed. Issue is still happening as of 4/8


ReplyQuote
juanantonio
(@juanantonio)
New Member
Joined: 6 months ago
Posts: 1
April 8, 2019 10:03 EDT PM  

The bug is definitely NOT fixed. Still having this issue as of April 8th. Does anyone know a temporary workaround?


ReplyQuote
Page 1 / 2
Share: