Clear all

Weird WiFi behavior  




here is my setup:

I have 3 Linksys Velop stations, one on each floor of my house. They are in bridge mode and connected to my router by ethernet cable. There is a lot of steel in my floors so I can be sure that I will switch station if I change floors. I can also see this phenomenon watching the bars on my iOS device walking on the stairs.

I have a HomePod located on floor 3 , connected to the station there via wifi. My iMac with my iTunes library is on floor 2, connect via ethernet (wifi is on because of the AppleWatch).

Here's what I do. I start out with my iPad and iPhone connected to wifi on floor 2 and go to floor 3 . There I start the remote app on the iPhone to start playing music from iTunes on my HomePod. I get the rotating circle and it tries to connect to iTunes. Most of the time it does not work. I get a connecting error after a while.

I started to turn wifi off and on an the iPhone after the connecting error. Sometimes it helps but not always.

By accident I discovered the following. Once I get the rotating circle on the iPhone, I fire up Mocca VNC on the iPad and connect to my iMac. As soon as the VNC is established, the circle on the iPhone stops and remote app connects to iTunes.

Updating to the new remote app only changed the "visual" experience. No more rotating circle but still the same behavior.

I don't get it. What is happening here? Any ideas?

Regards Juergen

6 Answers

There are several things at play here, difficult to diagnose from a distance.  I would suggest trying to streamline the connections and eliminate as much as possible to track down the root cause.

Example: You have both Ethernet and Wi-Fi enabled on your Mac with the iTunes library.  Check the priority/preferences in network settings, but ideally, disable Wi-Fi and have the Mac only connected via hardwire.

This will mean you can't use handoff or unlock with an Apple Watch, but the minor inconvenience is worth the trouble to help narrow down the issues.

I would also try to run iPerf3 or similar network throughput tests that are local and don't loop through an ISP or external website.  That will help measure lan-to-lan transfer speeds and see if there are local network problems with wired vs Wi-Fi. paths between devices.

Can you set different SSID's manually on the Velops.  I don't recall if they can do that. Most mesh systems are dumb and don't allow manual configuration.  If you can manually set different SSID's, then you can control which AP your iPhone is connecting to and test  better by forcing/controlling the AP in use instead of having the mesh and clients automagically trying to select the "best" AP and handing off on their off.

Client steering/roaming/hand-off are still the bleeding-edge part of Wi-Fi as standards are lean and cross-vendor compatibility not that great.  MU-MIMO isn't even supported yet by most client devices.

Those are the areas I would look at to try and narrow things down.

Ok, I will try one thing after another. I turned off WiFi on the iMac running iTunes.

There was something new yesterday. I was on floor 3 and running remote app on the iPhone. Display was on and I played a few songs. Then, all of a sudden, remote app lost the connection to iTunes and the rotating circle appeared. I grabbed my iPad and just for fun established a ssh connection to the iMac. But that didn't help. I initiated a vnc connection from the iPad a boom, remote app on the iPhone got connected again. 


The weirdest thing happened. I was trying to get the remote app to fail and noticed, that the AP was not responding. I checked with the Velop app and sure enough, the AP was unreachable. But the LED on the AP was showing the right color. Reseted it, still unreachable. Took it off power for a while and after powering it up again it behaved normally.

And since then I was not able to reproduce the problem. I'm sure that I was in the Velop app during troubleshooting many times and everything look fine. Maybe something went wrong at the last (automatic) firmware update, I don't know.

I'm happy now everything works, thanks for the help and knocking on wood that problem won't come back.


knocking on wood with you! 🙂


Just a question/idea - What is the nature of the Ethernet cabling used to backhaul the Velops?  

You might have a wiring problem - especially if using existing CATx cable that isn't rated or able to carry 1Gbit traffic which the bridge units RJ45 ports may be trying to do.

Most homes that were pre-wired by the builder typically use CAT 5 which is only rated for 100Mbit Ethernet, not 1000Mbit (GigE).  Totally not an issue until recently with broadband modems going higher than 100mbit which means your local network needs to run at GigE speeds - or may be trying to.

If you can, cable only one mesh unit directly to the router and use known certified CAT 5e cable. Let all the other units mesh via wireless only.

See if that makes any difference.

I'm not sure if the problem is related to that. If so, the connection should have problems most/all of the time.

But I only have the problem with the initial 'first' connection from the the remote app to itunes. Everything else (i.e. internet) works just fine. And once I initiate up a vnc connection to the computer running itunes from a device connected to the same base station it immediately works flawlessly.  


I have a 200Mbit internet connection. So, if I connect wireless to the AP on floor 3 and get that download speed, the cable of that AP should be able to give me gigabit, right?

Standing right next to the AP I tried it on the iPhone: 76Mbit

Using a laptop I get 200Mbit, trying the iPone again, also 200Mbit.

Next time I get the remote app problem I will test the speed right away and see if those two things are related.


This is driving me nuts.

Turning off wi-fi on the iMac running iTunes did not solve the problem. I now even had one instance were iTunes "lost" the connection to the HomePod and I had to vnc from the iPad connected to the same AP as the HomePod.

I'm beginning to wonder if using the mesh in bridge mode is the problem. I use a FritzBox (with integrated cable modem) as my router. Would I have to disable router capabilities in the FritzBox before activating routing in the mesh because to routers in one network are begging for trouble?



This sounds like one of those scenarios where the wireless-to-ethernet bridge is passing some but not all packets. I don't mean to say that changing from Bridge Mode to Router Mode would make a difference, though... I just mean the internal bridge in the Velops (or elsewhere) might be filtering out something important. 

I'm guessing (educated-ly) that HomePod uses Bonjour to allow devices to "discover" it, and we know that's what your Mac's iTunes library uses.

Bonjour will use Bonjour unless it already knows the address of the device. Connecting first with the VNC app solves the "what's the IP address of that device?" question and, boom, Bonjour has its answer so it can stop scanning/looking.

It's for this reason that I think something in your setup is blocking/filtering Bonjour's announcement packets.

The first thing to check is to double-confirm that your Velop is using bridge mode and not double-routing you. Bonjour generally won't hop subnets, so if your devices are on two separate subnets, that will do it. Check your iPhone's IP address in Settings > Wi-Fi > [little (I) icon by your chosen network] and compare that to the IP address of the Ethernet interface on your Mac. 

I've done a lot of testing with Linksys's Velop, and I've experienced several scenarios where one device doesn't properly inherit the settings change from the others... that may well be happening here, and your 3rd floor device might be in Router mode while the others are Bridging.

If that all checks out, though, the next thing I'd try is adding an Apple router in Bridge mode, just to A/B compare between connecting to the two different networks to see what happens there.