Battery not Charging

  • Posted: 24 February 2009 12:45 PM

    Originally, I posted this issue in Experts Exchange in October. I’ve found no solution yet. So, here I am. Here’s the original question:

    “A few weeks ago, my MagSafe adapter burnt out. Someone else was using the computer, didn’t notice, and the entire battery got depleted. Now, I replaced the MagSafe adapter. When I plugged it in, the MacBook worked, but the battery would not charge. I tried all the tricks, resetting the pram, getting the update, whatever. I then convinced Apple that the battery was bad, and they gave me a new one. So here I am, with a new MagSafe and new battery, and the thing still will not charge. The MacBook recognizes the battery, and it will run off the battery as well, but it will not charge it. I’ve tried other MagSafe adapters, tried cleaning the connector, tried taking the battery out and holding down the power button (while off), nothing works. I am hoping someone has a solution other than ‘buy a new logic board.’”

    Recently, there have been a few times the MacBook will give me the battery with an x, while other times it sees the battery but simply won’t charge it.

    Any help is appreciated.

  • Posted: 03 May 2009 10:16 AM #1

    If you have an Apple Store or AASP near you that would be your best bet. It’s likely an issue with one of three components; the logic board (worst case scenario), the battery (unlikely at this point) or the battery connector.

    This certainly sounds like a hardware issue though and I wouldn’t think its something you would want to try and resolve yourself.


    -Matt Cox / Mac Technician / Matt on Twitter