Snow Leopard Compatibility, Bugs and Quirks

  • Avatar

    Posted: 28 August 2009 10:10 AM

    Now that Mac OS X 10.6 is shipping, odds are we’ll all come across some unexpected compatibility issues and odd bugs. Have you found any issues yet, and if so, workarounds?


  • Posted: 28 August 2009 01:03 PM #1

    Several folks are reporting Apple Remote issues over at the Plex forums. When you use the remote the OS sends commands to iTunes and Front Row even if Plex is also handling them. I wonder if this affects other apps that use the remote, like VLC. There are other Plex issues too related to optical audio and fonts.

  • Avatar

    Posted: 28 August 2009 03:44 PM #2

    So far very happy with everything, especially the last-minute updates from Indev for Mail Act-On and from Shirt Pocket for Super Duper.  Those two things alone make my life easier.  Now if only Raging Menace would hurry up with the Menu Meters update, then Snow Leopard would again begin to feel like home. wink  You know, RM should charge for Menu Meters.  I’d pay for it!


    -Dave Hamilton / The Mac Observer / Mac Geek Gab / Dave on Twitter
    When you find a big kettle of crazy, it’s best not to stir it.

  • Posted: 29 August 2009 12:56 AM #3

    Disk Utilities keeps crashing on startup on my MacBook.  I tried “Repair Permissions” from the install disk with no success.

  • Avatar

    Posted: 29 August 2009 01:02 AM #4

    They say it will be a month or more to fix FinderPop, and SL busted Grammarian Pro X.  I am seriously thinking about reverting to Leopard until all of these apps I use are fixed.


    “A body in motion at a constant velocity will remain in motion until pushed out of bounds by the Strong Safety.”    ~  Issac Newton’s First Law of Physics

  • Posted: 29 August 2009 02:50 AM #5

    Interesting…. in the final stages of the install I was prompted to install Rosetta in order to use components of Office 2004. I’ve been weaning myself off of Entourage. Perhaps now it’s time to take the final steps. Mail has improved dramatically over the past few years.

  • Posted: 29 August 2009 03:13 AM #6

    Time Machine users: I suggest using Ethernet for the first post-install backup. My first backup is measuring almost 9 GBs. I don’t suggest trying to handle that backup over Airport.

  • Posted: 29 August 2009 03:38 AM #7

    I’m happy to report the Time Machine backup went smoothly.  grin

  • Avatar

    Posted: 29 August 2009 03:26 PM #8

    Install went good no problems on MacBook. But cannot install on MacBook Pro (oct 07).  Will not install on my HD, says cannot boot from this drive. I think it’s the partition I did while back to run Linux with boot camp.  All data backed up with time machine and superduper bootable image. Disk utility will not format the drive.  Not sure what to do next. Any Suggestions.

    Started up from external drive and reformatted. Restored from SuperDuper. Installing SL now. Looks like I just needed to get rid of the old partition. Fingers crossed.

    So it had to be the hacking I did a while ago to run linux via boot camp. After I restored the disk image, Snow Leopard installed. Took quite awhile but seen to be running good. Can’t blame any of the troubles on Apple.

    BACK UP!!!!!!!!!!!

    Last night, I decided in preparation of installing Snow leopard, I would update my bootable image with SuperDuper. But I have two external drives and I updated the image on the wrong one by mistake. I erased 20 years of photos! I didn’t realize it until after SL was finished installing and I launched iPhoto. Nothing, no photos. Back in February I moved all my photos to the “other” external drive to save space on the MBP HD. So the the iPhoto library could not be found.  I was crushed!  I could not believe I deleted my digital history just to install a new OS. But, it was not the new OS, or the fact that it’s a good idea to backup before installing. Simply I selected the wrong drive to update the disk image. So simple of a mistake.

    Enter Time Machine!  Say what you want about Time Machine, but in my case it saved my butt.  I found the backup file in February before I moved all the photos to the “other” external drive. In a small way, I think Apple software engineers had me in mind when they created the Time Machine thank you very much.  Up until today I kind of regretted even buying the Time Machine, all I wanted at the time was a good wireless router, didn’t really care about backups. But the interface is pretty cool so I set up the MBP to back up and forgot all about it until 15 minutes after I realized I deleted 20 years of photos.  Been a long day with some steep ups and downs.  and it still ” just works” thanks you….....

    [ Edited: 30 August 2009 03:28 AM by brinnt ]
  • Avatar

    Posted: 30 August 2009 10:20 AM #9

    My install went smoothly, and so far everything except iStat is working - it suffers from the same issue that Menu Meters has. I’ve used one or the other for many, many years, and I am jonesing!

    CS2 is working under Rosetta - I only tested GoLive and Photoshop.

    Synergy from our friend Wincent Colaiuta isn’t working…checking…I needed to update.  3.5.5a works just fine.

    Haven’t checked my audio interface(s) yet.  Or Logic 8 - Ummmm….works fine. Will report back later on the audio interfaces.


    Editor - The Mac Observer

    Favorite (but less relevant than it used to be) Quote: Microsoft’s tyranny lies not in its success, but in the way it achieved and maintains that success.

  • Posted: 31 August 2009 02:58 AM #10

    While Boxee (media center app) still works, I noticed it is not as stable as it used to be in Leopard.

  • Posted: 31 August 2009 07:41 AM #11

    Dave Hamilton - 28 August 2009 06:44 PM

    Now if only Raging Menace would hurry up with the Menu Meters update, then Snow Leopard would again begin to feel like home. wink  You know, RM should charge for Menu Meters.  I’d pay for it!

    I am lost without menu meters - not being able to easily see incoming outgoing traffic - didn’t realize how many times a day I looked up there.

    I agree I would pay for menu-meters, such a core application to have.  I am kind of surprised snow leopard does not provide such functionality as standard as an extension of activity monitor.  Amazing how many areas they leave open that developers then offer solutions too.

    Another program that seems to install but not working is smart trash, which allows you to delete items from just one volume, instead of all which the OS does.  But I found today that in Pathfinder (which I just love) right clicking on the trash can in the left drawer you can view trash or empty trash for specific volumes.  This a must for thumb drives to avoid leaving the hidden trash sitting there taking up space and confusing the hell out of anybody on windows machine who uses it.
    See screenshot of pathfinder trash can in action.

    Image Attachments

    Screen shot 2009-08-31 at ,Mon31 Aug,6.40 .jpg

    Click thumbnail to see full-size image

  • Avatar

    Posted: 31 August 2009 05:42 PM #12

    PLeased to report that my FastTrack Pro audio interface is working (though still not in iChat, of all places, but this was the case in Leopard).

    This is a 2x2 USB audio interface from M-Audio.


    Editor - The Mac Observer

    Favorite (but less relevant than it used to be) Quote: Microsoft’s tyranny lies not in its success, but in the way it achieved and maintains that success.

  • Posted: 31 August 2009 10:30 PM #13

    My load went fine. Everything went fin until I went to print. No print driver now for my printer. Down loaded it from HP. Now I see the printer. I get an error when I try to print. Utility prints a test page but errors when I print anything else.

    My toast 6 will not start at all now.

    Now I wait to see what else will not run.

  • Posted: 01 September 2009 12:43 AM #14

    My Snow Leopard install on a Mac Pro went perfectly.  There was a glitch, that’s been reported by others, on a MBP.  Wrote about that on Aug 31, a quick tip.

    ImageWell 3.4.3 failed.  Had to upgrade to 3.7.3.
    Filemaker Pro 8.5 was reported to not work. Deleted.  Already had 10.0 installed, Worked fine.
    Had to uninstall Symantec NIS first.
    Had done update to BusyCal prior.
    Can’t think of any other notable issues.
    The easiest major upgrade I’ve had with Mac OS X.

    Have not yet tried: Parallels 4.

  • Posted: 01 September 2009 04:25 AM #15

    Figured out Snow Leopard requires both IP addresses multi-homed to a single ethernet interface to be “good” addresses or IP networking doesn’t work at all. Went like this: Mini running 10.5.8 multi-homed with a static 192.168.1.x private address & a “real” (static) public address working fine on the network prior to upgrading. Here’s the catch: the computer was moved to a different location and network for the SL upgrade, so the public address was invalid at the new location. No problem, both locations used the same private network address range, so running 10.5.8 the existing static private address worked just fine at the new location, internet access unaffected. Immediately following the SL install, the machine could not get to software update, load web pages, etc. First thought access to the (single entry) remote DNS server went down because I could not ping it. So I added a local DNS server in Network system pref. No go. Next I changed the service order, putting the private address first (remember, with 10.5.8 it worked fine with an invalid public address at the top of the service order). Still didn’t work. So I set the invalid static public IP service (already now 2nd in the service order) to inactive. Bingo - networking immediately came alive, pings, SWUpdate, webpages flowing in…