My Ethernet port is toast, what do I do?

  • Posted: 05 October 2009 06:19 PM

    First of all, my computer - a MacBook Rev. B, 1.83GHz intel core duo with an incredible 512MB of RAM (yeah, I’m lazy), running 10.5.8, chronically kernel panics. Sometimes they’re worse - once every 15 minutes - other times I’m lucky enough to only have to see that irritating black box once every 4-6 hours. Either way, there hasn’t been a single day gone by in the past six months where this computer hasn’t kernel panicked.

    The initial problem with this computer was that the AirPort card started to get iffy. The hard drive suffered a pretty nasty head crash, and when I got a new HD (thank you AppleCare, that’s the one good thing you’ve done for me) and reinstalled OS X the computer showed the AirPort card as “not configured,” and all that showed up in Network prefs as viable options were Bluetooth and FireWire. It took an archive and install for the AirPort card to show up again, though now I’m not so sure that the reinstall really did anything to make the AirPort card work again. It still occasionally won’t show up or flakes out.

    Anyways, after that incident was worked out, the kernel panics set in. Usually after one kernel panic, the computer kernel panics again on startup, and then 75% of the time after that, the computer will start up normally. Here are the culprit kexts:
    Kernel loadable modules in backtrace (with dependencies):

    Also I will sometimes get this:
    unloaded kexts:   2.4.0 - last unloaded 93994632085
    loaded kexts:   2.4.0 - last loaded 15026348078

    I can post the full logs if need be. I’m trying to conserve space here.

    I tried deleting InternalModemSupport (hidden inside AppleIOSerialFamily, THAT was annoying), my logic being that since there is no internal modem in this computer, it must be confusing itself loading and unloading a useless kext, especially one compatible only with Tiger. Nope, didn’t fix it. Also considering that this issue continues no matter what system I’m running, it’s pretty safe to say that it’s hardware-related.

    After trying all this stuff, reinstalling, reformatting, trying different configurations, resetting PRAM, NVRAM, running AHT overnight, testing the RAM on memtest until i was sick of looking at black and white, checking out the firmware etc. etc…I finally noticed that there’s a freakin’ pin missing on the Ethernet port. A PIN! and I didn’t notice! And the port looks to be damaged in other ways, too… So what do I do? New computer is not an option right now, I’m not that great with a soldering iron and I’m sure a new logic board would be just as expensive as a new computer. Sigh…

    Oh, and a final sidenote: Whenever I open the Network pane of system prefs, it tells me “New Interface Detected”—ethernet, of course. I hate life. Oh wait, one more: When I start the computer in verbose mode, I get “AppleYukon2 - RomlessInit - getProperty failed”.

  • Avatar

    Posted: 06 October 2009 04:58 AM #1

    I have not got many ideas about kernel panics other than reinstall. As for the ethernet port only 4 of the 8 pins/wires in a RJ45 type connector are used pins 1,2,3 & 6 which usually corresponds to the orange and green pairs in most ethernet cables so a missing pin may not necessarily be the end of the port. The error messages you are getting with “Yukon” in though I think refer to a Marvell Yukon Ethernet adapter that is used by Apple. So assuming that it is the end of the port or other damage has occurred you could consider a usb to ethernet adapter, I believe that apple even make one of these primarily for the MacBook air as this does not have an internal Ethernet port.

  • Avatar

    Posted: 28 October 2009 10:34 PM #2

    I agree with what gregriley mentioned.. a USB to Ethernet adapter.  They are pretty cheap…

    I am not sure about the kernel panics either, other than it is probably related to the hardware issue, but I am not sure.

  • Posted: 02 November 2009 03:18 PM #3

    It could be related to the Ethernet port, but I’d check for bad RAM even if the hardware test said it’s OK. If you have two 256MB chips (rather than one 512MB), take one out and use it for a couple days. It will be noticeable slower, but see if the kernel panics go away. If it doesn’t help, put it back and take out the other chip. If you’re lucky, that’s the cause. Bad RAM is one of the most common causes for freezes, and luckily it’s also one of the cheapest things you can replace in your computer.