System freeze with iTunes

  • Posted: 03 November 2009 01:10 PM

    Got a strange problem with Snow Leopard that I was wondering if anyone had a solution for.

    If I run iTunes, and it has a lot to do (e.g. downloading podcasts, plus maybe a TV show, etc.), about half the time the entire system will freeze up. First iTunes becomes unresponsive, then things like the dock become unresponsive, and eventually (within about a minute), the mouse becomes unresponsive, and the system turns into a big brick, requiring a hard reboot.

    Any thoughts?


  • Avatar

    Posted: 04 November 2009 12:29 AM #1

    How much ram do you have? What kind of machine do you have? (CPU)

    You also might want to download Onyx and dump your cache files and reboot.

  • Posted: 04 November 2009 09:34 AM #2

    It’s an Intel iMac (24”) with 4 GB RAM. And yeah, I’ve tried cleaning caches using Cocktail, repairing permissions, etc.

  • Posted: 04 November 2009 12:24 PM #3

    I was having a few minor issues with 10.6 after I upgraded (occasional Finder freezes, plus some other apps). I was also having a hardware issue (my internal microphone was only recording white noise) so, to rule out an OS driver issue or something, I ended up reinstalling 10.6 from scratch on a formatted drive. Rather than migrate, I reinstalled all of my apps from scratch on a new account (I did use MobileMe sync to bring down address books, calendars, bookmarks, keychains, etc.), and manually migrated the rest of my data.

    It didn’t solve the microphone problem (that was fixed at the Genius Bar), but 10.6 has been rock-solid stable. If nothing else works (I’d probably try deleting iTunes preference files in ~/Library/Preferences, and maybe even reinstalling iTunes from, and you have a spare couple of hours, and excellent backups, it might be worth a try.

  • Avatar

    Posted: 08 November 2009 08:35 PM #4

    DargonMac: Does the console show anything here when this problem starts? I also wonder if it’s an issue with the hard drive. That’s a lot of data being written from a lot of sources, but shouldn’t be a problem unless there’s an issue with the drive.


    -Dave Hamilton / The Mac Observer / Mac Geek Gab / Dave on Twitter
    When you find a big kettle of crazy, it’s best not to stir it.

  • Posted: 21 March 2010 11:36 PM #5

    I have just about the same exact issue that DargonMac describes. I can’t nail down the circumstances that cause the freeze other than the fact that it usually involves multiple podcasts and / or iPhone apps being downloaded simultaneously. Here’s the scenario:

    - iMac 20” + 4GB ram
    - OS X 10.6.2
    - iTunes 9.0.3
    - HD partitioned into two drives: boot drive with apps (no changes made here to the standard Apple install) and a “data” drive. iTunes library resides on the “data” drive where permissions are ignored. I pointed iTunes to the library on this drive using the Option key when starting up iTunes.

    I set up a new user account and did encounter the same issue.

    I’ve seen the idea that this could be a hard drive issue, but a) I’ve run drive diagnostics with TT Pro and haven’t found anything (which of course doesn’t mean there isn’t something there), and b) there are no other indications at all that something is wrong—nothing else crashes like this.

    In addition, a few months back I completely reformatted the entire drive, re-partitioned it, and set everything back up. The problem continued after doing so.

    Any ideas? Would appreciate any thoughts!


  • Posted: 24 July 2010 12:42 AM #6

    Yep, I’ve been seeing the same thing too.  iMac 20” + 4GB ram.

    This has been happening to me for a while, but I think it’s only started happening since OS X 10.6.  Doesn’t matter if it’s iTunes 8 or 9, though.

    Distressing to hear that reformatting and reinstalling doesn’t solve the problem.  I was considering that myself.

    Even ssh refuses connections, so I can’t even see what’s going on then.  What’s so weird about it is that the mouse cursor works and the clock is updated, but I can’t click on anything.  After rebooting the logs aren’t helpful.

  • Posted: 12 October 2011 02:00 AM #7

    Wonder if anyone’s solved this? I have had the same issue through multiple erase-and-installs over time as well as upgrades to Snow Leopard and now Lion (just installed last weekend & have already seen this behavior). As before, it only (and much of the time) happens when downloading podcasts and / or apps, usually when many of them are in the download queue. Can’t nail down anything else going on in the system—sometimes it happens when only iTunes is running, other times when many other things are running, and peripherals don’t matter either. I’ve duplicated it in other user accounts as well.