iOS 4.2.1 and Not Charging When Plugged In

  • Posted: 30 November 2010 06:37 PM

    I’ve noted an interesting issue with my iPad since the 4.2.1 update.  About half the time when I plug in the 10W charger, I get the “Not Charging” notice at the top of the screen.  Under the original OS I noticed that the “Not Charging” notice wasn’t necessarily consistent with the same USB port on a computer, but that message never showed up when using the charger.

    I have both the charger that shipped with the device and the 10W one Apples sells (with a usuable length of cord) and both exhibit this behavior.  I suspect the problem is that the software has changed the sensitivity at which it will display the “not charging” indicator and not necessarily a true change—and I suspect now that the power cords are “marginal” when the display is on.

    I use the iPad for full day continuing education presentations for CPAs to hold the manual I lecture from, using GoodReader.  Battery life is always of interest, and this will be the first time I’ve run it with 4.2.1.  Normally I keep the plug nearby and park the iPad on the charger during breaks so when I fly back home after finishing up I have a decent charge available (since sometimes it’s going cross country to return home to Phoenix).

    I notice some scattered reports of this “not charging” issue on the net, but not an overwhelming number—so I’m wondering if it’s also related to hardware that also gives a marginal reading.  But I suppose I’ll find out soon enough if it’s a real issue or just a display issue when I give tomorrow’s course grin .

    I would be interested in seeing if anyone else is noticing this behavior.  I’m using a “first day shipped” 16GB Wifi iPad.

  • Avatar

    Posted: 07 December 2010 04:55 PM #1

    I, too, have a “first day shipped” WiFi iPad of the 32GB variety. I have no issue using mine with the included charger or the add’l 10W charger I purchased, and I’m running 4.2.1. To me this sounds like a hardware issue—hav eyou tried rebooting the iPad (shutdown, restart)?


    -Dave Hamilton / The Mac Observer / Mac Geek Gab / Dave on Twitter
    When you find a big kettle of crazy, it’s best not to stir it.

  • Posted: 07 December 2010 05:14 PM #2

    I have been waiting to post here until I was sure as I only picked uo my iPad last week. I have a 32GB WiFi only model running 4.2.1 and its charging without issue. Like Dave, I’d say it sounds like a hardware issue.


    -Matt Cox / Mac Technician / Matt on Twitter

  • Posted: 07 December 2010 09:17 PM #3

    I’ve rebooted the iPad and it still occurs.  Of course, it’s not consistent—sometimes plugging and unplugging it works to get rid of the complaint, and it’s more likely to happen if I plug the cord into the socket first and then attach it to the iPad.

    However, I’ve not found it failing to charge the device yet—it gets to a full charge and I don’t notice it’s much slower when that “Not Charging” note comes up than it was before 4.2.1 or than it is when it doesn’t show.

    For now I’ll put it into the “mysteries” file unless other symptoms show.  I have noticed sporatic mention of this issue elsewhere doing a Google search, but it’s clearly not something everyone sees—for instance, my wife’s iPad, which is identical to mine, never brings up this message when she plugs it in.

    I’m wondering if my battery reading to the OS is “on the edge” of where the iOS starts complaining about a slow charge, and 4.2.1 is simply more sensitive than was the original iPad OS.  I did notice that even earlier it didn’t always seem consistent on getting a “Not Charging” when plugged into a USB port on my MacBook Pro, though I figured it was just the difference in the two USB ports.

  • Posted: 08 December 2010 02:17 AM #4

    I am having the same issue after upgrading to ios4.2.  My 32gb “first day shipped” is displaying “not charging” while plugged into the proper wall charger and today I discovered iTunes will not recognize the device.  I have performed multiple “resets” and the issue remains.

  • Posted: 08 December 2010 10:26 PM #5

    I have seen reports online of the “not showing up in iTunes” complaint as well when the charging isuse shows up, though I haven’t noticed it although I don’t really often hook it to the Mac (I use it mainly for things other than video and music) except for doing the backup every so often.

    It’s clearly not happening to the majority of users because you don’t see tons of complaints—but it obviously happens to some.

    I guess as long as it keeps working for me I’ll leave things be until I finish up my trips this month.  Then I might try a Genius Bar trip (though I know the darned thing will work there given its inconsistent nature right now grin ).

  • Posted: 09 December 2010 11:17 AM #6

    Still too early to say this will work, but on two occasions here at the hotel in Portland it has worked.  When iPad plugged in and reports “not charging” I leave it connected to the power, turn it off and then turn it back on.  In the two times I’ve tried, when it has come back up it has indicated it was now charging.

    Will need to see if this continues to be a workaround.  As well, will check when I get back home to see if I can get the problem with iTunes not finding it and then see if the power on while connected to the Mac allows this to work.

    I have not had the iPad run out of power on me or behave as if it truly is not charging at all, but I’m still watching.