Issues with Ricoh printer

  • Posted: 20 September 2011 09:39 AM

    Hi guys,

    I’ve seen one similar post, but I couldn’t resolve my issue.

    I’m the only Mac user in the office and everyones had a few issues but now I’m the only person who cant print. Even our tech guy couldnt work it out. As I’m the graphic designer its soooooo important that I print out proofs etc, so any help would be appreciated.

    When I go to print, the Ricoh Aficio MP C2550 literally prints out a line of random jargon and then continues to churn out blank pages.

    I’ve attached an example below.

    Thanks in advance,


    Image Attachments


    Click thumbnail to see full-size image

  • Posted: 20 September 2011 11:49 AM #1


    Sorry, I really know nothing about big printer systems except to say that I have seen this before, but it was a long, long time ago. On a printer trying to print from a Windows 98 machine. It was a driver problem, then. Could your problem be a driver issue?

    Check out:

    I have to say, looking at a page like this, is a revelation. How many driver versions, a printer maker has to support. You sort of feel for them until you notice that not only do they seem to not have a driver update for Lion (understandable), but they don’t seem to have one even for Snow Leopard, considering how long 10.6 has been out!

    Well, at least they are seemingly staying current with updates for 10.5 (last posted January, 2011).

    If it worked and now it doesn’t and you haven’t upgraded the OS, or changed anything, do you think maybe re-applying the driver with the one they have for 10.5 would work to fix it?

    I don’t know. Someone please jump in and correct me if I am wrong, here.

    Hope you get your problem solved.

    Thank you so much for your patience at my curiosity.


  • Avatar

    Posted: 20 September 2011 12:06 PM #2

    It appears that the printer is not processing postscript commands correctly (or at all). As if it is set to PCL only.

    What you are seeing is the header for a postscript 3 file.