Mountain Lion Login - No cursor, mouse and keyboard inactive

  • Posted: 23 August 2012 12:46 AM

    I don’t have a cursor at login. Not responsive to mouse and keyboard (so no typing first letter of account).

    Some times I can get the cursor to appear by connecting via VNC on my iPad. Most of the time as soon as I connect I see the cursor.

    This last time I still couldn’t do anything via mouse or keyboard until I clicked on the Bluetooth menu item (via VNC) and then the cursor appeared and the keyboard began to work.

    Once keyboard and mouse start working it’s not an issue until I reboot.

    I have a wired apple keyboard. Kensington Turbo Mouse is connected to keyboard.

    I also have wireless Apple trackpad.

    Connecting Turbo mouse directly to computer does not seem to make a difference.

  • Avatar

    Posted: 23 August 2012 02:53 PM #1

    Bizarre. Does this also happen if you boot from the recovery partition (or CAN you boot from the recovery partition by holding down Cmd-R immediately upon boot)?


    -Dave Hamilton / The Mac Observer / Mac Geek Gab / Dave on Twitter
    When you find a big kettle of crazy, it’s best not to stir it.

  • Posted: 24 August 2012 12:49 AM #2

    It gets more bizarre. I haven’t tried the recovery partition or my cloned drive yet.

    Gambled and tried 10.8.1 update.

    Now, cursor visible, could move it with turbo mouse, but could not click on user account or use keyboard to select. Bluetooth trackpad wouldn’t move cursor.

    Back to VNC. Again, when I connect everything works.

    Connecting via Mocha VNC, wonder if the user name and password provided somehow triggers something.

    Hope I can solve this, have a nearby Apple store, but bringing in a Mac Pro…... what a pain.

  • Posted: 30 August 2012 10:58 AM #3

    When I tried to use option key to select booting from another drive, I was able to select the drive, but couldn’t get it to continue to boot to it (clicking on drive changed which was highlighted, but further clicking did nothing).

    Forcing shutdown with the power button, it booted the drive to an external drive running Mountain lion. Same symptoms. Switched to internal drive with Lion. Same thing.

    Both current (ML on SSD) and Ext drive running ML were migrated from the Lion drive, but all this started after I was using ML on the SSD full time.

    Hardware? My wireless trackpad batteries have been having issues, I’ll pull them.

    Only hardware change I’ve made recently was adding the SSD that is now the boot drive

    Symptoms not always same, sometimes cursor is visible, sometimes it’s not.

    I’ve also noticed that it doesn’t “fix itself” for several minutes after I’ve logged in using VPN from my iPad. Once the mouse and keyboard start working though, I don’t have issues with them.

    Only other oddity, has happened several times. I’m actively using the mouse and the screen goes black except for the cursor (as if I hit a hot corner for the screen saver). Clicking flashes the screen, but nothing else. Not sure if related

  • Posted: 14 September 2012 11:14 PM #4

    Problem resolved.

    Issue seems to have been some dying rechargeable batteries in my Magic Trackpad. Removing them resolved the issue. Added fresh batteries and I’m no longer having issues.

    Having the trackpad with bad batteries affect usage I understand…. why it cleared up after a few minutes to work well for days/weeks between reboots, that I don’t get!