Synology CloudStation Shared Folder File Permissions Problem

  • Posted: 16 October 2013 04:23 PM

    Hi all.

    I’m hoping to get some help with my Synology DiskStation since Dave is a big fan and John reluctantly gave into peer pressure and bought one. smile

    I’m running the latest DSM and CloudStation client on a DS413. I have no problems with using CloudStation for my own account. However, I have also set up a Shared Folder on the DS and given access to both of the accounts currently on the DS. Files will sync correctly, but I am really looking for Dropbox-like functionality. I want to be able to save a file to my local copy of the shared folder and have it sync to the DS so my partner can view/edit the files in his local copy. The problem is, when the files get written locally, the permissions are rw-r—r—. So, only the person who created the file can edit it. If I log on to the DS via SSH and change the permissions, as soon as the file is edited, the permission revert to rw-r—r—. With Dropbox, shared files are writeable by anyone with access to the shared folder. I worked a lot with Synology support, but in the end, they said it’s the way UNIX permissions work.

    Any ideas on how to make this work like Dropbox?


    - Leon

  • Posted: 26 October 2013 04:38 AM #1

    Hi Leon,

    I just bought a DS213+ , so I’m also new to it. I experienced the same problem, but managed to make my shares accessible to both users. I just checked it in terminal and a new file I just created on my NAS has the following permissions: -rw-rw-rw-@
    Is this what you want? Sorry, my terminal skills are not that great, I mostly live in the luxury of the GUI.

    I had to change the permissions in two places: 
    1   Control panel >  Users > 2x click on the user >  Privileges setup > tick Read/Write
    2   2x click on File Station > select the share > Right mouse button, choose Properties > Privileges setup > tick Read/Write for the user who needs access.

    Hope this helps.


    [ Edited: 26 October 2013 04:43 AM by Frank V ]      
  • Posted: 28 October 2013 10:47 AM #2

    Thanks for the reply, Frank. I tried changing the privileges as you suggested, but it didn’t make a difference. After playing around some more, I decided to try setting up a new folder on the NAS. With that folder, I have no problems sharing files. As soon as I try to use CloudStation, the file permissions get messed up again. I suspect there is an issue with CloudStation and AFP. The good news is that I can still use CloudStation for files that aren’t shared, so it’s not totally useless. Maybe they will fix this soon.


    - Leon