iMac Sleep Problems

  • Posted: 09 March 2011 03:36 PM

    Wonder if any of you can help, some months back I started to notice that my late 2009 21.5” iMac was not going to sleep.
    This week I finally got around to trying to sort this out.  a bit of background about my setup.

    I have an my iMac connected via ethernet to an Airport Extreme with my Time Machine Backup and one other network drive attached.  this is set up as my wireless router but the DHCP server is provided by by Cable Provider supplied Virgin Media SuperHub, which also has attached to it via ethernet my AppleTV, the AppleTV is synced with my iMac’s iTunes, both of which are regularly controlled from an iPad, my wife’s iPhone or an old iPod Touch (all connected via Airport wirelessly).
    Attached to the iMac via USB Hub I also have an CanoScan 8800f scanner (usually turned off), and a HP Photosmart c4780 Printer (usually left on).

    I reduced the timeout window write down to 1 min to help with fault finding. 
    After 1 minute the screen would blank but the imac would not go to sleep.

    I did some googling and found out that USB devices in general and specifically HP Printers can cause sleep problems, so unplugged the USB Hub.
    No Change

    I then tried forcing it to sleep and noticed that it would wake immediately.
    More google and I ran a terminal command to find what woke it “.. reason =  ” (blank)

    Closed Down all open applications (inc Carbonite, Dropbox and LogMeIn) but excluding iTunes (nothing playing though), as I want to be able to stream music to AppleTV
    No Change

    I have it set to wake from the LAN so that I can wake it up using the AppleTV when I’m away and log on using LogMeIn, and not sure what impact this would have on streaming I assume it would not support it.  I tried pulling out Network Cable to see if that helped.
    I could now force it to sleep but not automatically.

    Connected back ethernet, and could not force sleep.  Connected by Wifi and can Force Sleep, but not auto.

    Shut down iTunes
    No Change

    Reset PRAM
    No Change

    deleted power management plist
    no change

    checked in Console, no error message when it fails but still can’t get it to sleep automatically.

    As part of writing this just checked and Wake on Lan off with Ethernet in does allow forced sleep but not auto.

    Anyone got any ideas on how I track down what is causing this.

    Thanks for any help.

  • Avatar

    Posted: 09 March 2011 10:36 PM #1

    Try uninstalling the HP software.

  • Posted: 10 March 2011 05:49 PM #2

    tried that still no luck

  • Avatar

    Posted: 10 March 2011 06:49 PM #3

    Suggestion list, no order of priority (yet)  (you might have already done these, sorry for any redundancy)

    1. try using a 2nd user account
    2. In the Energy Saver panel of System Preferences, uncheck “wake for network access”.
    3. reinstall latest Combo Update
    4. make other adjustments in Energy Saver
    5. Inspect all processes in Activity Monitor.

  • Posted: 12 March 2011 03:27 AM #4

    Thanks, tried all these with no luck.

    I even tried booting from a fresh install on a USB drive and this has the same issue so I reason it must be something wrong with my hardware, I’m booked in to see the genius bar guy on Sunday, hopefully they can track it down.

    Will let the forum know the outcome.

  • Avatar

    Posted: 13 March 2011 11:34 AM #5

    6.Replace all USB or Bluetooth devices.    And / or, inspect for sticking keys. 
    7. Inspect for a power button which is sticking.

  • Posted: 17 March 2011 07:20 PM #6

    so I took this in to the Genius bar and they were not really much help, the problem did not seem to be the same there any they fobbed me off with a “it’s going into a different type of sleep” answer, which I was not entirely convinced by so some more investigatin myself.
    I think i have narrowed it down to network based, I can get it to auto sleep if I disconnect ethernet and turn wifi off.
    I can also get it to auto sleep by turning “wake on network access” off.
    75Unfortunately the problem with that is I can no longer wake it with a magic package sent from my AppleTV.  (this used to work and does wake if turned on an force sleeped).

    I’m sure I have had this previously work and to be frank if I can’t wake it remotely then I’m not sure I want it to sleep.

    activity monitor showns lots of processes anyone got any ideas of what to look for or how to kill / restart them to fault find ?

  • Posted: 17 March 2011 09:05 PM #7

    Hmm, is there anything else that could be sending data to the computer to keep it awake? Such as your router transmitting error/access logs?

  • Posted: 18 March 2011 03:22 PM #8

    There could well be either the Appletv or airport ?
    How would I find that out ?

    Although thinking about it I’m pretty sure I have also tried it with my wireless hotspot and seem to recall I got the same results.  Will check again tonight.

    [ Edited: 18 March 2011 03:25 PM by Jon Webb ]      
  • Posted: 18 March 2011 05:22 PM #9

    Just checked and I get the same problem as soon as I turn airport on, even if no wireless networks are connected.
    So in summary the problem occurs if either Ethernet is connected or airport is turned on, and “wake for networks access” is checked in energy saving pref pane.
    Turning “wake for network access” off clears the problem with both wifi and ethernet, however I need that on to wake remotely with a magic packet.

    Not sure if this is related but in the console log I see “[0x0-0x224224] preferences[5058]    Couldn’t find any match”. Error when I try and change the energy pref pane.

    [ Edited: 18 March 2011 05:40 PM by Jon Webb ]      
  • Posted: 18 March 2011 05:42 PM #10

    Here is an extract from the activity log, in case that helps:

    Active Memory: 844.4 MB
    Free Memory: 482.3 MB
    Wired Memory: 603.7 MB
    Used Memory: 3.53 GB
    Inactive Memory: 2.11 GB
    Total VM: 144.01 GB
    Number of processes: 60

    PID   Process Name         User     CPU     Real Mem     Virtual Mem  
    0     kernel_task           root     2.2     155.2 MB     1.71 GB      
    1     launchd             root     0.2     1.0 MB       2.34 GB      
    10   kextd               root     0.0     2.7 MB       2.34 GB      
    11   DirectoryService       root     0.1     9.5 MB       2.34 GB      
    12   notifyd             root     0.2     616 KB       2.32 GB      
    13   diskarbitrationd       root     0.0     2.0 MB       2.33 GB      
    14   configd             root     0.0     3.1 MB       2.36 GB      
    15   syslogd             root     0.0     772 KB       2.34 GB      
    16   distnoted           daemon   0.0     1.4 MB       2.33 GB      
    17   blued               root     0.0     5.5 MB       2.35 GB      
    18   mDNSResponder         _mdnsrespo 0.0     2.5 MB       2.34 GB      
    23   securityd           root     0.1     4.4 MB       2.35 GB      
    27   coreservicesd         root     3.9     32.5 MB       2.39 GB      
    29   ntpd               root     0.0     1.1 MB       2.32 GB      
    30   cupsd               root     0.0     10.3 MB       2.35 GB      
    31   nmbd               root     0.0     1.4 MB       2.32 GB      
    32   krb5kdc             root     0.0     2.3 MB       2.33 GB      
    39   ptmd               root     0.0     2.7 MB       2.33 GB      
    40   mds               root     0.1     116.2 MB     2.55 GB      
    41   loginwindow           Clare     0.0     14.0 MB       2.66 GB      
    42   KernelEventAgent       root     0.0     1.1 MB       2.33 GB      
    44   hidd               root     0.6     1.4 MB       2.33 GB      
    45   fseventsd           root     0.0     3.4 MB       2.34 GB      
    47   dynamic_pager         root     0.0     788 KB       2.32 GB      
    53   autofsd             root     0.0     988 KB       2.33 GB      
    71   WindowServer         _windowser 5.4     89.6 MB       2.75 GB      
    78   cvmsServ             root     0.0     872 KB       2.33 GB      
    92   coreaudiod           _coreaudio 0.0     4.6 MB       2.34 GB      
    122   launchd             Clare     0.1     1.5 MB       2.34 GB      
    126   Dock               Clare     1.1     25.7 MB       2.67 GB      
    127   SystemUIServer         Clare     0.0     37.4 MB       2.72 GB      
    128   Finder             Clare     0.9     38.3 MB       2.71 GB      
    134   fontd               Clare     0.0     5.0 MB       2.38 GB      
    138   pboard             Clare     0.0     840 KB       2.32 GB      
    141   UserEventAgent         Clare     0.0     5.5 MB       2.35 GB      
    151   CarboniteStatus       Clare     0.0     3.7 MB       889.3 MB      
    152   1PasswordAgent         Clare     0.0     8.8 MB       2.60 GB      
    153   imagent             Clare     0.0     2.7 MB       2.60 GB      
    155   Folder Actions Dispatcher Clare     0.0     5.0 MB       2.60 GB      
    161   GrowlHelperApp         Clare     0.0     40.2 MB       2.64 GB      
    259   check_afp           root     0.0     1.1 MB       2.33 GB      
    340   AppleSpell.service     Clare     0.0     9.1 MB       2.35 GB      
    2225   Safari             Clare     0.0     178.1 MB     4.96 GB      
    2286   WebKitPluginAgent       Clare     0.0     996 KB       2.34 GB      
    2376   RFBRegisterMDNS       root     0.0     1.7 MB       2.33 GB      
    2378   RFBRegisterMDNS       root     0.0     1.7 MB       2.33 GB      
    4531   AppleVNCServer         Clare     0.0     3.7 MB       2.59 GB      
    4989   Activity Monitor       Clare     17.0   27.5 MB       2.74 GB      
    4991   activitymonitord       root     8.8     1.3 MB       2.33 GB      
    5030   smbd               root     0.0     2.5 MB       2.34 GB      
    5031   smbd               root     0.0     332 KB       2.33 GB      
    5040   usbmuxd             _usbmuxd   0.0     1.6 MB       2.35 GB      
    5095   Console             Clare     0.0     26.5 MB       2.68 GB      
    5110   mdworker             _spotlight 0.0     3.8 MB       2.35 GB      
    5115   mdworker             Clare     0.0     16.7 MB       2.36 GB      
    5144   Mail               Clare     0.1     54.9 MB       2.73 GB      
    5146   ocspd               root     0.0     1.8 MB       2.35 GB      
    5147   PubSubAgent           Clare     0.0     13.6 MB       2.36 GB      
    5148   SyncServer           Clare     0.0     6.0 MB       2.35 GB      
    5152   Flash Player (Safari Inte Clare     0.0     19.8 MB       931.7 MB

  • Avatar

    Posted: 18 March 2011 11:16 PM #11

    Can you logout and then sleep ?  (probably, if I am understanding your first post)

    Another method is to use Keyboard Maestro to force a sleep, which I do nightly.

  • Posted: 19 March 2011 07:03 AM #12

    not sure about the logout and sleep I have not tried that but yes I can force the sleep with alt, cmd eject.

  • Avatar

    Posted: 04 May 2011 08:35 PM #13

    I have a 24” imac wireless to the time capsule which contains the time machine back up and the wireless router.
    Well, once I went to snow leopard I found that my mac DOES NOT STAY ASLEEP ..and it is because TIME MACHINE wakes the guy up when the hourly back up starts.

    THIS DOES NOT HAPPEN in my other IMAC in another location that has a WD external hard drive holding the time machine back up, JUST THE SYSTEM where the TIME CAPSULE from APPLE has the time machine back up.

    What did I do. I gave up. I leave the timecapsule-hooked up imac (the 24”)  machine on all the time in its secure network (its at home and there are only 2 of us here) and put the display to sleep very quickly so its a dark screen most of the time. During the day I or hubby are on the machine all day so to be honest, we never slept it anyway when we were awake.

    I tried all that stuff you did about USB and all that jazz until I just sat and stared at the machine when it was asleep until it woke up and then that’s how I found out. Let me tell you, I’m not cut out for police secret service jobs. It is BORING to just watch something that isn’t changing!


  • Avatar

    Posted: 04 May 2011 10:46 PM #14

    Can you change the scheduling ?

    Plan at Mark

  • Avatar

    Posted: 05 May 2011 11:52 AM #15

    to your questions about the schedule: There is no idiots approach to changing time machine back up scheduling so I just don’t do it.  I am not really a tinkerer with my Mac but others might have all kinds of ways to do this. Maybe someone else will reply to your question.
    My approach isn’t really causing me any grief to be honest.

    When I go away on trips (over to where the IMAC has the WD hard drive external as the time machine back up) I completely shut down the IMAC that is connected to the time capsule. When I start it back up, Time Machine starts right in making back ups and is very nice to tell me “it has been more than 30 days since you made a back up” right before it starts in.

    One thing here - on the time capsule that is wireless to my imac but also has ethernet possible -for the start up , I make sure it is connected via the ethernet not wireless, at first, to the time capsule (it forgets where the back up drive is for some reason when I start up in wireless mode). Also ethernet is faster for all the software updates I always need to do on return.

    [ Edited: 05 May 2011 11:54 AM by tammythemongoose ]